PaperCut Hive - some devices may show server or connection errors.

Incident Report for PaperCut Software

Resolved

This incident has now been resolved.

If you are still experiencing issues, please ensure that the device has been completely restarted.

We know this may have been disruptive and appreciate your patience. We’ll continue to monitor closely and will complete a full review of the incident.
If you experience other problems please report this via https://www.papercut.com/support/
Posted Sep 01, 2026 - 18:52 UTC

Investigating

PaperCut Hive - some devices may show server or connection errors. For example "Error: Server Error. The server encountered an error and could not complete your request. Please try again in 30 seconds."

We're currently investigating reports of some devices may show server errors or connection errors. This is impacting logging into some devices and releasing print jobs from those devices in the US hosting region.

We are not currently aware of impact to other regions.

We will provide updates here as they become available.
Posted Sep 01, 2026 - 14:44 UTC
This incident affected: PaperCut Hive & Pocket (US hosting region - PaperCut Hive & Pocket).