Mobility Print - customers unable to enable Cloud Print for the first time

Incident Report for PaperCut Software

Resolved

This issue has now been resolved. We'll be working internally to ensure that new Mobility Print customers will not encounter this issue in the future.
Posted May 10, 2022 - 10:28 UTC

Investigating

Please note that there is no impact to customers who have already enabled Cloud Print - this will only impact customers attempting to enable Cloud Print for the first time.

We have determined that a cloud service misconfiguration is preventing customers from enabling Mobility Print's Cloud Print feature for the first time. Customer will see a warning message with the text: 'Seems something's gone wrong - Cancel and try again'.

We're working on resolving this asap.
Posted May 10, 2022 - 02:30 UTC
This incident affected: PaperCut Mobility Print (Cloud Print).