Intermittent issues with logging into (and ordering) on PaperCut Partner Portal
Incident Report for PaperCut Software
Resolved
This issue has now been resolved and has not occurred since.
Posted Oct 03, 2023 - 03:37 UTC
Monitoring
After initial investigation, the issue has since resolved itself - the problem occurred between ~1:30PM PDT to 3PM PDT. The underlying cause seems to be cloud infrastructure related and is currently being investigated.
Posted Oct 02, 2023 - 17:29 UTC
Investigating
An issue has been identified with intermittent issues to our Partner Portal which resulted in degraded performance in placing orders and quotes in our order system. We are currently investigating.
Posted Oct 02, 2023 - 17:28 UTC
This incident affected: Order System (buy.papercut.com) and Partner Portal (portal.papercut.com).