PaperCut Hive - some users experiencing issues with the user interface and releasing print jobs.

Incident Report for PaperCut Software

Resolved

This incident has been resolved.
Posted Mar 20, 2026 - 23:45 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Mar 20, 2026 - 23:22 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Mar 20, 2026 - 22:07 UTC

Update

We are investigating the active incident jointly with our cloud infrastructure service partner, and will update here as soon as we have more information.
Posted Mar 20, 2026 - 21:19 UTC

Update

We are actively investigating this incident, currently we have engaged our cloud infrastructure service partner. Our joint teams are working together to resolve the issue.
Posted Mar 20, 2026 - 19:11 UTC

Update

We are continuing to investigate this incident.
Posted Mar 20, 2026 - 16:06 UTC

Investigating

PaperCut Hive - some users have reported intermittent issues with releasing print jobs, scan jobs failing, and navigating sections of the admin UI within the US hosting region.

We’re actively working to resolve the issues and will provide updates as they become available.
Posted Mar 20, 2026 - 14:41 UTC
This incident affected: PaperCut Hive & Pocket (US hosting region - PaperCut Hive & Pocket).