PaperCut Partner Portal - login failures

Incident Report for PaperCut Software

Resolved

Systems are all functioning as expected - please reach out to customer.service@papercut.com if you have any issues.
Posted Sep 11, 2023 - 11:12 UTC

Monitoring

We are still currently monitoring systems to ensure they are running smoothly.
Posted Sep 11, 2023 - 06:48 UTC

Update

We have now exited maintenance mode and things should be working as expected, and we are currently monitoring systems to ensure they are running smoothly. Please reach out to customer.service@papercut.com if you notice any issues.
Posted Sep 11, 2023 - 05:09 UTC

Investigating

We are currently updating our ordering system, and as a result, the order system, and PaperCut Portal will be unavailable until 5pm on Monday the 11th September (AEST).
Posted Sep 10, 2023 - 16:47 UTC
This incident affected: PaperCut Partner Tools (Partner Portal (portal.papercut.com)) and PaperCut Website (Order System (buy.papercut.com)).