PaperCut Pocket and Hive - Performance Degradation
Incident Report for PaperCut Software
Resolved
While we continue to improve the performance of PaperCut Pocket & Hive, we have returned the system to full functionality.

Until the root cause is resolved, there is potential for slower than usual printing performance to return, however we have identified changes and optimisations to the product to improve overall stability and latency.

Even though this specific incident is now closed, our work with Google and our cloud provider continues with the same urgency.

[Update 13th May AEST] The root cause of the issue has been resolved by Google and all systems are back to normal.
Posted May 12, 2022 - 03:30 UTC
Update
We are working closely with Google to identify the root cause of the performance issue and continue to deploy updates to PaperCut Pocket and Hive to minimise customer impact.
Posted May 10, 2022 - 23:09 UTC
Identified
We are continuing to work with Google and our cloud provider to determine the root cause of this performance issue.

In the meantime, the team is updating the PaperCut Pocket and Hive services to make them more resilient - and minimise the effect of these upstream provider issues.
Posted May 09, 2022 - 06:37 UTC
Investigating
PaperCut Pocket and Hive are experiencing intermittent timeouts in printing and within the admin interface.

We are working with our cloud provider to identify the root cause.
Posted May 09, 2022 - 00:00 UTC
This incident affected: PaperCut Pocket & PaperCut Hive.