Logins to hive.papercut.com fail with error "Your account does not have access to this organization." with a non-US data center Hive account.
Incident Report for PaperCut Software
Resolved
This issue is now resolved. You can now login to any data center via the global login.papercut.com URL, and product specific URLs such as hive.papercut.com.
Posted Jan 22, 2025 - 02:41 UTC
Investigating
We're currently looking into issues where users logging into hive.papercut.com are unable to log in if their data center is hosted in a non-US region. The error message displayed is "Your account does not have access to this organization."

Currently logging in directly to your *regional* data center login page is working successfully - e.g. a user in the UK data center can successfully log in through uk.hive.papercut.com, an EU user through eu.hive.papercut.com and an AU user through au.hive.papercut.com.

All other functionality (printing and device access) is not impacted by this issue.
Posted Jan 21, 2025 - 14:40 UTC
This incident affected: PaperCut Pocket & PaperCut Hive.