PaperCut Hive & Pocket - Some customers may experience print job release failures in the US hosting region

Incident Report for PaperCut Software

Resolved

This incident has now been fully resolved. We have confirmed that print jobs are releasing successfully for multiple customers.

Our apologies for any downtime that you experienced as a result of this outage. We will be performing a full retro, as we do with all issues that impact our customers.

If you experience other issues please report this via https://www.papercut.com/support/.
Posted Mar 13, 2026 - 20:05 UTC

Monitoring

Monitoring and customer reports have confirmed that print release functionality has been restored. No action is required by customers to resume printing.

We are continuing to monitor this incident. If you're still experiencing issues please report this via https://www.papercut.com/support/.
Posted Mar 13, 2026 - 18:36 UTC

Identified

Our engineering team has identified the contributing cause of print release failures and a fix has been deployed to mitigate these issues.

We will continue to provide updates as they become available.
Posted Mar 13, 2026 - 17:11 UTC

Investigating

We are currently investigating an issue affecting print job release for customers hosted in the US data region.

Symptoms: Users may experience a "502 Error" (Something went wrong and the jobs weren't able to be printed) when attempting to release print jobs.

Our engineering team is actively working to identify the root cause. We will provide a further update as soon as new information becomes available.
Posted Mar 13, 2026 - 14:34 UTC
This incident affected: PaperCut Hive & Pocket (US hosting region - PaperCut Hive & Pocket).