We have confirmed that activities for PaperCut Hive & Pocket in the EU data center, and doc proc activities for PaperCut MF in the EU data center are all processing successfully.
Our apologies for any downtime that you experienced as a result of this outage. We will be performing a full retro and incident analysis, as we do with all issues that impact our customers.
We are continuing to work with our Cloud Partner on a resolution.
Posted May 07, 2025 - 07:04 UTC
Update
We are continuing to work on a fix for this issue.
Posted May 07, 2025 - 05:02 UTC
Update
We are continuing to work on a fix for this issue.
Posted May 07, 2025 - 04:15 UTC
Identified
The issue has been identified
Posted May 07, 2025 - 04:08 UTC
Update
We believe the issue appears to be with our upstream service provider, and we are working with them on a resolution
Posted May 07, 2025 - 04:04 UTC
Investigating
We are currently investigating reports that logging into the EU data center Admin Interface is currently unavailable, and print release may be experiencing degraded performance.
We believe EU Cloud Document Processing for both PaperCut MF and PaperCut Hive are also effected.
Our automatic monitoring picked up an issue with the EU DC around 3:11am UTC.
The Incident Team are actively investigating, and this status will be updated as soon as we have more information.
Posted May 07, 2025 - 03:44 UTC
This incident affected: PaperCut MF (Document Processing Cloud services) (EU hosting region - PaperCut MF (Document Processing Cloud services)) and PaperCut Hive & Pocket (EU hosting region - PaperCut Hive & Pocket).