Intermitted issues Portal and Ordering system
Incident Report for PaperCut Software
Resolved
The issue has been resolved.

We are reviewing the issue and logs to work to find out the root cause of the issue but for now, this issue is resolved and systems are back to being fully operational.
Posted Oct 17, 2023 - 20:49 UTC
Investigating
We have reports of users having issues accessing the PaperCut Portal and the MF ordering platform.

The issues seems to be intermitted and only affecting some users.

We are investigating the issue
Posted Oct 17, 2023 - 20:21 UTC
This incident affected: Order System (buy.papercut.com) and Partner Portal (portal.papercut.com).