PaperCut Partner Portal and GES (licensing service) - some users unable to access the Partner Portal, or apply licenses in PaperCut NG/MF

Incident Report for PaperCut Software

Resolved

This incident has now been resolved.

We know this may have been disruptive and appreciate your patience. We’ll continue to monitor closely and will complete a full review of the incident.
Posted Aug 25, 2026 - 00:51 UTC

Update

We are continuing to investigate this issue.
Posted Aug 24, 2026 - 23:57 UTC

Update

We are continuing to investigate this issue.
Posted Aug 24, 2026 - 23:20 UTC

Update

This issue is also impacting some users' ability to activate a new license in PaperCut NG/MF (under About > Registration).

Error shown in the admin interface may be "Unable to contact PaperCut Gateway Service to register license file. Ensure your server is online and try again." or "The supplied CRN is invalid".

We are continuing to investigate these issues.
Posted Aug 24, 2026 - 22:11 UTC

Investigating

PaperCut Partner Portal - some users receiving Authentication Error during login
We're currently investigating reports of some users receiving an Authentication Error during login. This impact is being observed in all regions.
We will provide updates here as they become available.
Posted Aug 24, 2026 - 17:46 UTC
This incident affected: PaperCut Partner Tools (Sales Portal (partner.papercut.com), Partner Portal (portal.papercut.com)) and PaperCut MF Global Entitlements Service.