PaperCut Hive - users unable to log into devices

Incident Report for PaperCut Software

Identified

We have identified the root cause impacting MFD related tasks, including device login, scanning, and general access to functions on the device.

Our engineering team is actively developing and validating a fix to restore full functionality to the Hive Embedded App. Until the fix has been deployed to production, users may continue to experience degraded performance when carrying out these actions at the device.

Interim Workarounds:
- Use the PaperCut Hive mobile app (iOS and Android) for print release.
- Manually reinstalling the Hive embedded application will immediately restore MFD functionality.

We will provide a further update as soon as we have confirmation of the deployment timeline.
Posted Mar 03, 2026 - 20:07 UTC

Update

We have confirmed that this incident is now isolated to the US hosting region; all other regions have returned to normal operation.

While functionality has been restored for the majority of organizations in the US hosting region, we are continuing to investigate residual issues affecting MFD login and print release via the Hive embedded app. In the interim, we recommend using the PaperCut Hive mobile app (iOS and Android), which remains fully operational and unaffected.
Posted Mar 03, 2026 - 19:11 UTC

Update

We are continuing to investigate this issue. We will provide an update as soon as we have more information
Posted Mar 03, 2026 - 16:11 UTC

Update

Users may experience successful logins and subsequent print release issues. We are continuing to investigate.
Posted Mar 03, 2026 - 15:46 UTC

Investigating

PaperCut Hive - users may receive errors when attempting to log into devices

We’re actively working to resolve the issues and will provide updates as they become available.
Posted Mar 03, 2026 - 15:41 UTC
This incident affects: PaperCut Hive & Pocket (US hosting region - PaperCut Hive & Pocket, AU hosting region - PaperCut Hive & Pocket, UK hosting region - PaperCut Hive & Pocket, EU hosting region - PaperCut Hive & Pocket, CA hosting region - PaperCut Hive & Pocket).