PaperCut Hive & MF-S Order Portal Outage
Incident Report for PaperCut Software
Resolved
The issue has now been resolved. Quotas and orders can now be generated for both PaperCut Hive and MF-S. If you continue to encounter any issues, please reach out to https://support.papercut.com
Posted Jul 18, 2024 - 10:55 UTC
Investigating
We are investigating an issue affecting the ability to generate quotes and orders for PaperCut Hive and MF-S.
Posted Jul 18, 2024 - 10:25 UTC
This incident affected: Order System (buy.papercut.com).