PaperCut Hive & Pocket Outage

Incident Report for PaperCut Software

Resolved

We experienced disruption related to our cloud service provider and a serious level of temporary degradation was experienced by some customers when accessing print queues or releasing print jobs. All services have now been restored.
Posted Feb 24, 2026 - 15:00 UTC

Monitoring

Our services have returned to normal and we will continue to monitor the incident closely.
Posted Feb 24, 2026 - 14:42 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Feb 24, 2026 - 14:40 UTC

Update

We are continuing to investigate this issue.
Posted Feb 24, 2026 - 14:30 UTC

Investigating

We are currently investigating an degradation in performance with PaperCut Hive and PaperCut Pocket.
Posted Feb 24, 2026 - 14:30 UTC
This incident affected: PaperCut Hive & Pocket (US hosting region - PaperCut Hive & Pocket, AU hosting region - PaperCut Hive & Pocket, UK hosting region - PaperCut Hive & Pocket, EU hosting region - PaperCut Hive & Pocket, CA hosting region - PaperCut Hive & Pocket).