PaperCut Blog - Unresponsive
Incident Report for PaperCut Software
Resolved
The issue has been resolved.

We have identified the issue as an intermediary system failure between the website and the blog. We are already in the process of removing this system to ensure that this sort of failure does not occur.
Posted Jun 15, 2022 - 17:22 UTC
Investigating
We are currently investigating an issue that is causing the www.papercut.com/blog to be unresponsive.

The issue seems to be isolated to the Blog with the main website, support pages and manuals and all working as expected.
Posted Jun 15, 2022 - 16:15 UTC
This incident affected: Public Website (www.papercut.com).