PaperCut Document Processing Cloud services - some users may experience delayed scan jobs using PaperCut MF or PaperCut Hive

Incident Report for PaperCut Software

Resolved

This incident may have impacted scan actions with cloud document processing enabled, for a small window per hosting region between 03:40 - 05:10 am on 25th August 2026.

We know this may have been disruptive and appreciate your patience. We’ll continue to monitor closely and will complete a full review of the incident.

If you experience other problems please report this via https://www.papercut.com/support/
Posted Aug 25, 2026 - 05:10 UTC

Investigating

PaperCut Document Processing Cloud services - some users may experience delayed scan jobs using PaperCut MF or PaperCut Hive.

Printing, copying and other services are not impacted at this time. Any scan actions which do not include cloud document processing are also not impacted.
Posted Aug 25, 2026 - 03:40 UTC
This incident affected: PaperCut Hive & Pocket (US hosting region - PaperCut Hive & Pocket, AU hosting region - PaperCut Hive & Pocket, UK hosting region - PaperCut Hive & Pocket, EU hosting region - PaperCut Hive & Pocket, CA hosting region - PaperCut Hive & Pocket) and PaperCut MF (Document Processing Cloud services) (US hosting region - PaperCut MF (Document Processing Cloud services), AU hosting region - PaperCut MF (Document Processing Cloud services), UK hosting region - PaperCut MF (Document Processing Cloud services), EU hosting region - PaperCut MF (Document Processing Cloud services), CA hosting region - PaperCut MF (Document Processing Cloud services)).