Cloud Node was offline for accepting new jobs
Incident Report for PaperCut Software
Postmortem

A new release of the PaperCut Cloud Node included a misconfiguration that caused it to report as being unhealthy to the cloud system, even when healthy.

This caused the system to not provision new Cloud Node services and so during this time the Cloud Node functionality was unavailable.

Regular printing was unaffected as the Edge Mesh handles all printing without requiring the Cloud Node’s involvement. However situations where the Cloud Node was required would have failed during this window.

It was discovered that monitoring was insufficient on the Cloud Node services, and so it was able to be non-functional for this time period without triggering alerts. This has since been rectified, and the Cloud Node is now actively monitored.

Posted Dec 05, 2022 - 01:04 UTC

Resolved
The Cloud Node (optional component for PaperCut Pocket & Hive) was offline during this period due to a system misconfiguration. Normal printing was unaffected during this time, but situations requiring the cloud node functionality would have failed.

Issue period was from ~05:30 30/11/2022 UTC until ~11:30 1/12/2022 UTC
Posted Nov 30, 2022 - 05:30 UTC
This incident affected: PaperCut Pocket & PaperCut Hive.