Multiverse issue
Incident Report for PaperCut Software
Resolved
Problem has been identified and backend components adjusted to ensure the same issue does not re-occur
Posted Jan 13, 2022 - 10:16 UTC
Update
Things should be back to normal, we're keeping an eye on it
Posted Jan 13, 2022 - 09:12 UTC
Identified
A backend problem effecting the AU region is being investigated
Posted Jan 13, 2022 - 09:11 UTC
This incident affected: Multiverse.